Galaxie Forum Full-size Ford, Lincoln, and Mercury DazeCars www.galaxieforum.com


This forum is for all years of the Ford Galaxie and all other Full-size Ford, Lincoln, and Mercury cars. This is a place to share information, skills, pictures, and stories for the purpose of building friendships and furthering the enjoyment and restoration of these cars

You are not logged in. Would you like to login or register?



February 12, 2020 3:50 pm  #1


The 351W on my engine run stand is squirting..

Megasquirting that is.

Fired it up yesterday for the first time. I haven't read my plugs yet but fuel distribution seamed good. Headers seamed even temp wise after 15 minutes run time.  I don't have the IAC working correctly yet and I have to prime it to get it started but once its running it runs well. I'm sure if I change some setting I can fix both of those issues... Just not sure yet which setting to change

https://dazecars.com/dazed/IMG_3886.MOV


I have included some older posts below that show what has gone into this project.

Daze wrote:

Back in 2005 I bought a Megasquirt kit and built the ECU but never did anything more with it but now that I have the engine run stand I decided to fuel inject the 351W sitting on the stand.  I am going to squirt it using a "modified" Ford CFI unit. Attached are some pix of the CFI unit with descriptions of the changes I am making.

This is the CFI unit I am working with. Came from an 84 Grand Marques for a 302. has 46# injectors and the restricted 1.1" bore
https://imageshack.com/a/img923/2926/ncZheL.jpg


Another shot of the unit before I modified it.
https://imageshack.com/a/img921/1774/iTuiz6.jpg


This is the adapter plate that makes it all possible. I will be ditching the CFI fast idle and using an EFI FIS in its place, ported to this adapter.
https://imageshack.com/a/img923/2670/RI8aDo.jpg


This is all the junk I removed from the CFI unit.
https://imageshack.com/a/img922/2543/PDmuHZ.jpg


The CFI looks better with out all the junk. Since this pic was taken I cut off the fast idle bracket in the back left side.
https://imageshack.com/a/img921/7422/NuuPhV.jpg


The IAC will mount in this approximate location using an adapter plate, some fuel line and some inverted flair to pipe thread adapters.
https://imageshack.com/a/img923/6328/1N6GX2.jpg


here we have the adapter plate drilled and tapped. In the front there are two small ports, one for the distributor and another for the ECU. The big port id for the PVC line. In the back the nipple has been replaces with the inverted flair I mentioned earlier.
https://imageshack.com/a/img921/6463/RHj3Ym.jpg


Shot from underneath. Fuel proof thread sealant will be used on all the pipe threads.
https://imageshack.com/a/img921/6513/QPP6Zm.jpg


As I mentioned earlier the bore of the CFI was restricted to 1.1" so I chucked it up in a lathe, opened it up to match the 1.56" of the butterfly bore and then tapered the top 1/2" to open it up to 1.7". Should really help flow more air.
https://imageshack.com/a/img923/7008/VIuNZI.jpg


Another shot to better see the machine work on the bore.
https://imageshack.com/a/img924/4837/BdRtTq.jpg


The above was the original work I did to it and now this is the recent progress I have made on the project:
I made a fuel rail and added two injectors to the setup.
https://imageshack.com/a/img923/2/3CMWI5.jpg


https://imageshack.com/a/img922/4697/x0se8i.jpg



This is the assembled unit.  I removed the plug from a machining hole up stream of the pressure regulator and that is now the source for the fuel rail fuel
https://imageshack.com/a/img923/7686/0GOyMG.jpg


I plumbed the base to allow for a PMW IAC The "A1" and "A2" fittings will be connected with a hose and the other fitting is for the PVC hose
https://imageshack.com/a/img924/7427/ebA9dn.jpg


Another shot of the assembly and IAC
https://imageshack.com/a/img921/9246/h68Kgo.jpg


I also had to drill and tap the throttle linkage stop to accept an initial idle screw.
https://imageshack.com/a/img923/4672/64Og3s.jpg


The only other thing I had to do was create an adapter plate made out of 1/8 aluminum that goes between the CFI unit and the 2-4 adapter.  The two patterns were similar but not identical so I wanted make sure I had no vacuum leaks.

Daze wrote:

As many of you know I am all about DIY, and to that end I am always trying to expand what I can do at home.  Recently anodizing aluminum became one of those things.  I looked into it some years back but didn't want to deal with the battery acid to make the anodizing solution.  Recently I was interested in doing it for my Ford CFI/Megasquirt project and found this article.  It talks about using PH down instead of sulfuric acid.  The PH down is easier to get and much easier to work with and when you dissolve it in water you get sulfuric acid and salt.  The salt has no negative effects on the anodizing and the process works very well.  Cast aluminum is one of the hardest things to anodize due to the other metals used to make the casting alloy but even so I was able to dye all my parts black and have the added benefit of a hardened surface.  To get the matt finish I sandblasted everything prior to anodizing it.
https://imagizer.imageshack.com/img922/425/9jwLqh.jpg


A few things I did learn in the process is to use actual anodizing dye,  practice first, and it is better to anodize a piece for about 2 hours rather than shorter times to maximize the anodizing and in turn the ability of the metal to take on color.

Practicing is important for two reasons, first it takes a little bit to get the process worked out, and second you need to condition your solution.  Some kits come with aluminum powder to add to the solution, but since I didn't buy a kit it was important to do some test pieces to add a little bit aluminum to the solution.

Here is a shot of my anodizing station
https://imagizer.imageshack.com/img923/7517/tbfh2s.jpg


From left to right: power supply ($50 on Amazon),  anodizing tank, lye tank for stripping anodizing and etching pieces prior to anodizing and the heated dye tank.

Daze wrote:

My megasquirt project is getting closer.  
https://imagizer.imageshack.com/img924/4529/iP8V20.jpg

This is the relay board that makes connecting the ECU to all the engine parts, much easier.
https://imagizer.imageshack.com/img922/6273/9AEKiv.jpg


I need to add a port for a second temp sending unit and slightly modify my IAC/vacuum port set up and then we will be ready to fire it up IF I can figure out the tuning part.  As an aside I have a new sniper EFI setup sitting on a shelf but this is more fun. https://cdn.boardhost.com/emoticons/happy.png


 

 

 

February 15, 2020 1:16 pm  #2


Re: The 351W on my engine run stand is squirting..

Daze,
This is amazing stuff! Your fab skills and DYI continue to amaze!

 

Board footera

 

Powered by Boardhost. Create a Free Forum